• Mostrando resultados da busca por {{ posts_busca["corrected"] }} {{termo_busca}}
  • {{post.title}}
  • Não foram encontrados resultados para {{ posts_busca["corrected"] }} {{termo_busca}}

Contornar dificuldades na instalação do Moodle 2.7+

Gabriela Souza - Analista de Operações de Hosting N1 na KingHost

As versões mais atuais do Moodle (2.7 ou superiores) requerem um banco de dados mais atual. Devido a esse fato, pode ser que durante a instalação, você encontre alguns erros como os exemplificados abaixo:

Erro: Seu banco de dados utiliza Antelope como formato de arquivo. O suporte completo da codificação UTF-8 no MySQL e o MariaDB requer o formato de arquivo Barracuda. Converta para o formato de arquivo Barracuda.
Erro: Para suporte total do UTF-8, o MySQL e MariaDB exigem que altere a sua configuração MySQL ‘innodb_large_prefix’ para ‘ON’.
Erro de instalação no Moodle 2.7 ou superiores
Erro de instalação no Moodle 2.7 ou superiores

Como corrigir a dificuldade?

Você precisará entrar em contato conosco via telefone ou chat ou então abrir um chamado solicitando a migração do seu banco de dados MySQL para a versão 5.7. Depois de alterada a versão você já pode executar novamente a instalação do Moodle 2.7 sem acontecer erros.

Selecionou o banco Mariadb e gerou outro erro?

Até as versões 3.0+ se o você selecionar Mariadb ao efetuar a instalação pode gerar o seguinte erro:

Erro: Wrong $CFG->dbtype: you need to change it in your config.php file, from ‘mysql’ to ‘mariadb’.

Nesse caso a solução é bem simples, basta ir no arquivo config.php no seu FTP e alterar de:

$CFG->dbtype  = 'mariadb';

Para:

$CFG->dbtype  = 'mysqli';
Oi! Eu sou Gabriela Souza e quero te convidar para assinar nossa newsletter e ficar por dentro das novidades.
Enviar conteúdo por email
1546 visualizações

Esse artigo foi útil pra você?